to display the results of the regression formula on the chart type ?

SupportCommunity FPScript to display the results of the regression formula on the chart type ?

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Autor
    Beiträge
  • #12471

    Hello,

    On my chart, I have a curve data and a linear regression line, and I’d like to display the results of the regression formula on the chart type
    A.X = Y + B.
    How does one on FlexPro?

    Thank you in advance for your reply

    Example:

    #8144

    Hello,

    On my chart, I have a curve data and a linear regression line, and I’d like to display the results of the regression formula on the chart type
    A.X = Y + B.
    How does one on FlexPro?

    Thank you in advance for your reply

    Example:

    #8765
    Bernhard KantzBernhard Kantz
    Moderator

    Use the analysis object Linear Regression (New|Curve Fitting|Linear Regression) to calculate the linear regression. Choose the result type Dynamically calculated regression coefficients. Rename the analysis object into “Regression”.
    Insert a label in the 2D-diagram with the content: Y = %{Regression[0]} + %{Regression[1]} * x

    support@weisang.com

    #8766

    Why when I use “Calculate regression” coefficients calculated are accurate
    (in our example a = 0.2359 …, and b = -4.4705 …)

    But showing on the curve, the result is not the same!

    #8767
    Bernhard KantzBernhard Kantz
    Moderator

    The script is correct. We cannot reproduce your problem. Perhaps the diagram is not up-to-date. Please click on Update or Force Update.

    If this suggestion doesn’t solve your problem, please send your database together with the information about your FlexPro version (8.0.xx) to support@weisang.com.

    support@weisang.com

    #8768

    I found the problem, I had not checked the right option that is “the result type Dynamically calculated regression coefficients”
    thank you for everything

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.