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Getting to Know FlexPro in just 15 Minutes

This tutorial provides you with a brief overview of the structure of FlexPro and the basic command methods.

Before you start, it is vital that you read this first topic, since it will  provide you with important information on getting

started:

Managing Data with FlexPro

Alternative Import Options

Entering Data Manually into FlexPro

Importing Excel Data

Importing Data from Measuring Devices

Importing Text Data (ASCII Files)  

Analyzing and Presenting Data

Creating and Editing Diagrams

Creating a Document

Calculations in FlexPro

Automatic Presentation and Calculation of Data with the Press of a Button
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Managing Data with FlexPro

FlexPro stores all  objects generated by you such as data sets, diagrams, folders, etc. in a project database that appears

in FlexPro's main window. The object l ist shown above in the FlexPro window already contains some objects as

examples. When you start FlexPro, these sample objects will  not appear.

Structure of FlexPro's Main Window

· Ribbon

This is where you select commands. The ribbon is divided into several tabs. Only one tab is active at a time. The

example above shows the Home tab. You can switch tabs by clicking on the tab title. The commands are divided into

groups whose names appear below the icons. The FlexPro documentation uses the following syntax to refer to a

command: Tab[Group] > Command, e.g. Home[Clipboard] > Copy. Some icons open menus from which you can choose

an entry. This can be identified by a small arrow next to or under the icon; for instance: Home[Clipboard] > Paste >

Paste Special.

· Quick Access Toolbar

This displays frequently used commands that you can always access without having to change tabs.

· Folders Window

This is where folders created by you are displayed. You can select one particular folder here and its content then

appears in the object l ist.

· Object List

For instance, if you create a new data set or a diagram, it will  appear as an object in the object l ist. This allows you a

general view of all  objects that you are working on, such as data, diagrams and formulas.

· Data Explorer

Depending on the view selected, Data Explorer displays fi les on your hard disk or indexed data.

· Object Hierarchy
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This window presents the objects displayed in the object l ist in a hierarchical structure. You can therefore simply

reconstruct which objects are l inked directly or indirectly with a particular object.

· Preview

In the Preview window, the content of one object in the object l ist or selected in another window, such as a data set, is

displayed. This provides you with an overview of the object's content without having to double-click to open it.

· Data Preview

Data Preview is an advanced preview window specifically designed for data sets. The data set just selected is

displayed there as a curve. You can use data cursors to measure the data or enlarge a section.

· Properties Window

This powerful window allows you to quickly edit the properties of selected objects.

· Dynamic Help

This window offers selected topics and procedures related to the object that you are currently processing or to the

window in which you are currently working. Simply click on a help topic to display it.

· Workspace

Here, the windows of open objects appear on tabs. In addition to the object l ist, folders can also be opened in a

window here. The above il lustration shows the Data view of an open folder, which shows all  data sets contained in the

folder in a data grid.

Note   If necessary, you can undo any steps you make in FlexPro. Just click on the Undo/Redo icons in the Quick Access

Toolbar.

The next step depends on the format of your data. Select one of the four options:

Entering Data Manually into FlexPro

Importing Excel Data

Importing Data from Measuring Devices

Importing Text Data (ASCII Files)
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Entering Data Manually into FlexPro

In the Folders window, right-click on the root folder displayed in the top line and select Open in the context menu to

open it [1].

Enter the first two columns of the numerical values shown above in Data View [2]. FlexPro automatically creates the two

objects DataSet and DataSet2, which appear in the object l ist.
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To check the data, you can select a data set in the object l ist [1] and view its content as a curve in the Preview [2].

Caution: The following examples in this tutorial are based on imported data. Please select one of the alternative import

methods that you want to use:

Importing Excel Data

Importing Data from Measuring Devices

Importing Text Data (ASCII Files)
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Importing Excel Data

Click on the Data tab on the ribbon [1] and in the Import Settings group select the options as shown in the picture [2].

Click [Import from Files and Databases] > Excel File [3].

The Import dialog box opens. Switch to the folder C:\Users\Public\Documents\Weisang\FlexPro\<%

VERSION_COMMERCIAL%> or C:>Users>Public>Public Documents>Weisang>FlexPro><%VERSION_COMMERCIAL%>. From

there, switch to the subfolder Examples\Data\First Steps\Excel data and select Measurement 1.xls [1]. Click

Open [2].
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FlexPro automatically recognizes the data set structure present. You can verify this by looking at the value displayed for

Columns found [1]. Click Finish [2].

Note   When you import your own data, you may have to configure the settings on the next pages of the wizard so that

the data is interpreted correctly. You can save all  settings made in the wizard to quickly import data with the same data

structure in the future. To do this, select the Save import schema option on the last page of the wizard.

In the Verify Units dialog box, FlexPro displays all  imported unit symbols.

The column Interpreted as shows that all  units were imported correctly.

Close the dialog box.
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To check the data, you can select a data set in the object l ist [1] and view its content as a curve in the Preview [2].

Next: Creating and Editing Diagrams .

16
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Importing Data from Measuring Devices

Click on the Data tab on the ribbon [1] and in the Import Settings group select the options as shown in the picture [2].

Click on [Import from Files and Databases] > Binary Data [3].

The Import dialog box opens.

Switch to the folder C:\Users\Public\Documents\Weisang\FlexPro\<%VERSION_COMMERCIAL%> or

C:>Users>Public>Public Documents>Weisang>FlexPro><%VERSION_COMMERCIAL%>. From there, switch to the

subfolder Examples\Data\First Steps and select Measurement 1.DDF [1]. Click Open [2].

Note   If you expand the File Type list, all  available import options will  appear.
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In the Verify Units dialog box, FlexPro displays all  imported unit symbols.

The column Interpreted as shows that all  units were imported correctly.

Close the dialog box.

To check the data, you can select a data set in the object l ist [1] and view its content as a curve in the Preview [2].

Creating and Editing Diagrams .

16
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Importing Text Data

Click on the Data tab on the ribbon [1] and in the Import Settings group select the options as shown in the picture [2].

Click [Import from Files and Databases] > Text Data [3].

The Import dialog box opens. Switch to the folder C:\Users\Public\Documents\Weisang\FlexPro\<%

VERSION_COMMERCIAL%> or C:>Users>Public>Public Documents>Weisang>FlexPro><%VERSION_COMMERCIAL%>.

From there, switch to the subfolder Examples\Data\First Steps\Text data and select Measurement 1.txt [1].

Click Open [2].
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FlexPro automatically recognizes the data set structure present. You can verify this by looking at the value displayed for

Columns found [1]. Click Finish [2].

Note   When you import your own data, you may have to configure the settings on the next pages of the wizard so that

the data is interpreted correctly. You can save all  settings made in the wizard to quickly import data with the same data

structure in the future. To do this, select the Save import schema option on the last page of the wizard.

In the Verify Units dialog box, FlexPro displays all  imported unit symbols.

The column Interpreted as shows that all  units were imported correctly.

Close the dialog box.
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To check the data, you can select a data set in the object l ist [1] and view its content as a curve in the Preview [2].

Next: Creating and Editing Diagrams .

16
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Creating and Editing Diagrams

Use your left mouse button to select the data set Voltage [1]. Next, click on the Insert tab of the ribbon [2]. Open the Line

[3] menu and select Lines [4].

Note:   If necessary, you can undo any steps you make in FlexPro. Just click on the Undo/Redo Symbols on the Quick

Access Toolbar.
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The new diagram is inserted into the object l ist [1] and is opened in the workspace [2]. Click [Cursors] > On/Off to

activate the data cursors [3].

Using Cursors to Measure Data Sets
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Move your mouse pointer to the left Y axis where one of two cursors is located. A horizontal double arrow appears. Hold

the left mouse button down and move the cursor to the right [1]. The current values for the positions of the cursors are

displayed in the Coordinates window [2].

Spreading the Curve in a Diagram

Clicking on the Spread [1] icon enlarges the signal section between the cursors. Use the scrollbar [2] to move the

stretched data set within the diagram.

The Restore Image Section [3] icon allows you to undo all  zoom operations in one step.
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Switch off the cursors using [Cursors] > On/Off in order to edit the diagram.

With one click of the left mouse button on the curve of the diagram, this curve can be selected for editing [1]. Using the

Line Color [2] menu, you can now change the color of the curve, for instance.
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Double-clicking with the left mouse button on the selected curve [1] opens the Properties dialog box for the curve. This is

where all  options for changing this curve are displayed. Now close the Properties dialog box by clicking on Cancel [2].

Note:   Double-clicking on any element (axes, scaling, etc.) opens the respective Properties dialog box automatically and

allows you to work with the element.
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Creating a New Y Axis

Click on the scaling of the Y axis using the left mouse button. The numerical values appear highlighted [1].

Move your mouse pointer to one number on the Y axis. For example, click on the number 0.4 and hold down the left

mouse button. Now also press the CTRL key. The mouse pointer now displays an additional + sign. Move the mouse

pointer to the white space to the right of the diagram [2]. Now release the mouse button [3]. A new axis is added at the

selected position. In the next step, a data set will  be scaled over this new axis.
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Adding a Second Data Set to the Diagram and Scaling Over the New Axis

In the object l ist, cl ick on the data set called Current. Press and hold down the left mouse button [1].

Move your mouse pointer to the new axis [2]. Release the mouse button [3]. The Current data set appears in the diagram

and is automatically scaled over the new axis.

Note   If the object in which you want to insert an element via drag-and-drop is located on a tab in the background and

is therefore not visible, move your mouse pointer to the tab of the target object and wait a moment. FlexPro will  then

bring the window to the foreground.
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This is how your diagram now looks with two data sets and two Y axes. Now close the diagram by clicking on the Close

icon in the window tab.

Note   Click the 2D Diagram object in the object l ist. Now you can copy this diagram to the clipboard or use drag-and-

drop to copy it into a Word document, for example.

Next: Creating a Document .

24
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Creating a Document

The Document

A document is the equivalent of a piece of paper on which you can place diagrams, text and tables and then print it out.

Creating a Document

Click on the Insert[Containers] > Document to create a blank document.
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Displaying a Diagram in a Document

Select the appropriate diagram, in this case 2D Diagram, from the object l ist [1]. Next, drag this diagram to the document

by holding down the left mouse button and placing it where you want it to be located [2]. After releasing the button on

your mouse, the diagram is displayed in the document [3].

Note   In this case, a l ink to the diagram located in the object l ist is inserted into the document. You can see this as a

link icon, which appears on the mouse pointer. To insert a standalone copy of the diagram into the document, you have

to hold down the CTRL key and mouse button at the same time.

Inserting a Row of Text into a Document

Click Design[Il lustrations] > Label [1] and then move the mouse pointer to the location where you want the label in the

document [2]. Click to open the Edit Text dialog box.
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Now enter the appropriate text [3], select font size 20 [4], heading level 1 [3] and click OK [4]. The text will  then appear in

the document.

The inserted text can now be moved with the mouse.

Now close the document.



27

Note   If you activate the cursor using the Document Design[Cursors] > On/Off icon and click on the diagram in the

document, all  of the cursor options become available to you in the document. You can also create multi-page documents.

Calculations in FlexPro .

28
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Calculations in FlexPro

Select the data set in the object l ist called Ultrasound Signal [1]. In the Preview you can see the shape of the signal.

Next, from the Insert[Analyses] > Spectral Analysis [2] menu select Fourier Spectrum [3]. FlexPro now creates an analysis

object for calculating the Fourier spectrum.

 In the Properties dialog box, which is now opened, leave all  settings unchanged and exit by clicking OK. The spectral

analysis is performed for this example using the default settings in the dialog box.
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In the object l ist, the analysis object is displayed with the name Ultrasound SignalSpectrum [1]. This represents the

spectral analysis of the ultrasound signal and can be used like a data set. To display this calculated spectrum in a

diagram, select Insert[Diagram] > Line > Lines [2].

The new diagram with the spectral analysis is then displayed in a new window. Now close the diagram.
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Note:   You can also set up your own calculations as FlexPro formulas. Wizards are available to assist you with this

process.

Next: Automatic Presentation and Calculation of Data with the Press of a Button .

31
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Automatic Presentation and Calculation of Data with the

Press of a Button

Create a new document by clicking on Insert[Containers] > Document.
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Select the data set in the object l ist called Ultrasound Signal [1]. Drag this data set to the document by holding down the

left mouse button [2] and placing it where you want it to be located. After releasing the mouse button, the data set is

displayed in the document [3].

Note   You can drag a data set directly into a document without creating a diagram first. If you do this, a diagram is

automatically created within the document.

Now select the diagram called 2D Diagram2 [1] with the spectral analysis and place this diagram within the document

by selecting the diagram in the object l ist with your left mouse button and, while holding the mouse button down, drag

the diagram to the desired location in the document [2] and drop it there [3].
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You now have a finished document with the ultrasound signal and the spectral analysis of this signal from Measurement

1.

All  objects from which you have assembled your evaluation form a dynamic network, which is displayed in the Object

Hierarchy window. You can thus use the evaluation directly as a template for evaluating additional measurements.

Import the fi le Measurement 2 from the data folder.

You can find information on the relevant import options under:

· Importing Excel Data

· Importing Data from Measuring Devices

· Importing Text Data (ASCII Files)

In FlexPro, a second folder called Measurement 2 is now created and activated (distinguished by the red folder icon) [1].

The content of the active folder is displayed [2] and all  open windows are updated, since the option Home[Update] >

Automatic is selected [3].
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Note   You can switch between the individual measurements at any time by selecting the appropriate subfolder from the

Activate or deactivate subfolder l ist box at the top of the Folder [4]. FlexPro updates all  windows automatically as long

as the option Automatic Update is selected. Otherwise, you can also carry out the update manually using the Update All

command [5].

If you want to, you can now try out other options available in FlexPro. Here are a few suggestions:

· Double-click on the object UltrasoundSignalSpectrum and convert the spectral format from dB to amplitude.

· Create statistics for measured data and display these as a table within the document.

· Export the complete analysis as an HTML web page.

· Record a few command steps as a macro.

· Create a formula for calculating data sets.

Search the Online Help for the relevant Help topics.
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The FlexPro setup includes additional sample project databases covering a wide range of topics.

The examples can be found in the folder C:\Users\Public\Documents\Weisang\FlexPro\<%VERSION_COMMERCIAL%

>\Examples or C:>Users>Public>Public Documents>Weisang>FlexPro><%VERSION_COMMERCIAL%>>Examples.

Topics covered include:

· Presentation examples

· Analysis examples

· Examples of measurement series analyses

· Data query and document collection

· FPScript examples

· Order tracking examples

· Other examples (SPC, roundness, etc.)
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